Ally “What To Do”
This guide is a work in progress. It tries to outline a process for accessibility allies to run through when working on a course. Collectively we will improve, update, and correct this document based on your experiences and recommendations.

Logging your work
You will use three main tools:
1. Teams files area
a. A subfolder for each Blackboard course should be placed here, and within it the original course files from before you started remediation.
2. A “main excel file”
a. Each Accessibility Ally has a tab/worksheet with their name.
b. This is used to note the starting accessibility score, and accessibility score once remediation work ends.
c. A formula calculates the percentage increase.
d. This data is held in this file to make it quick and simple to demonstrate the benefits of the project.
 The Process – Part 1: Starting work on a course

1. Create a new folder in the Teams files area, name it with the course id of the course (e.g. COMP1234-56789-21-22)
2. In the Blackboard course, expand course files from the Control Panel and 
a. Select All Courses Content.
b. A list of courses you have access to is shown.
c. Tick the box to the left of the course you are working on.
d. Select the Download Package button.
e. A zip file will be generated called courses.zip, 
f. Save it to your computer, 
g. and rename it to courseid.zip e.g. COMP1234-56789-21-22.zip 
h. and then upload it within the folder you created in step 1. 
i. Note that you can map the corresponding sharepoint folder to your computer to make this faster.
i. If the zip file does not download, or you receive error messages, let the team know before continuing.
3. Within the “main excel file”: place the course id, start date, and the accessibility score. 
The Process – Part 2: Working your way through a course

1. Enter the course in Blackboard. These are possible ways to approach the work:
a. Work your way through the course content areas in a logical order, and open the accessibility indicator of the content, and proceed through resolving issues that Ally identifies
b. Open the Accessibility Summary from the Control Panel and
i. Work through fixing content with the easiest issues to fix.
ii. Work through fixing the low scoring content.
iii. Use the View button and work through all files, you can order this list by accessibility score.
c. In the first few courses we recommend trying out all approaches, taking notes on the effectiveness of each, and sharing this feedback to the group. Hopefully we will find a consensus on the best approach.
2. Repeat the process for each file that has issues.
The Process – Part 3: Finishing your way on a course

1. Once you complete remediation of a course, check the new course accessibility score, and add it to the “main excel file”.
a. Add also the date you finished and any important short note about the course.
2. A meeting will be arranged to discuss the work with the course instructor.

 Dealing with “non-file” content
Most content that we should concentrate on will be files that have been uploaded to a Blackboard course. Ally may also identify issues with content that has been created using Blackboard’s text editor.
Ignore Announcements
Announcements are ephemeral, they are only relevant for a short period of time and will not usually be copied forward to a new academic year. Do not edit announcements. This is because an email notification will be created and the date the announcement was edited will be changed.
Dealing with content created using the text editor
Usually you can alternative text directly within the Ally screen. If you decide to correct issues within a content item you can edit it and use the Accessibility checker to identify where the issue is.
[image: The accessibility checker appears within the text editor within the third row. It looks like a silhouette of a person.]
Figure 1- Text  editor with accessibility checker encircled in red.

Going beyond the issues Ally finds
Questions to consider when using ally to resolve accessibility issues.
Tables
Where tables are used, is the content tabular data? Are there empty cells. Could the table be presented in a better way to aid accessibility?
Old PowerPoint templates
Does the presentation use an old template? Is it in 4:3 aspect ratio? Would it benefit from being in a contemporary University template?
Templates can be found on the Communications SharePoint site.
Use the Office Accessibility Checker
Use the Office accessibility checker, resolve issues that it identifies if possible. Log any issues that require subject matter expert knowledge to resolve.
Note that what Accessibility Checker says should be done for Word tables will not achieve the best result. The best method I have found is below.
Apply other best practices?
· Avoid justified text
· Avoid centred text
· Avoid text in all caps
· Make sure colour is not the only use of conveying meaning.
· Hyperlinks underlined
· Font
· Change filenames so they are consistent and meaningful?
File is an HTML file
Ally will check HTML files for many issues. However, resolving these issues may be more complex than expected depending on the nature of the file.
If HTML files are found to have issues, log them for now and we will assess best approaches collectively.

File is a Word document
Is the file a .doc file, not a .docx?
Using a copy of the file, save it as a docx file. In the accessibility checker choose for it to be updated to work with the accessibility checker.
Visual scan both the original .doc file and the new .docx file and verify that the presentation and content of the .docx document has not been negatively impacted.
Error: The document does not have any headings
WCAG (Web Content Accessibility Guidelines) 2.1 - 1.3.1 Info and Relationships
Major issue
Notes
This accessibility check is currently only enforced for Word documents that contain a minimum of 12 paragraphs.
Word will not highlight if there are no marked-up headings. The document creator may have used bold, changes in font size etc to indicate ‘headings’
Explanation
This document doesn't contain any marked-up headings. Headings are important as they provide structure to a document, especially those that consist of many pages. When headers are properly and consistently used, the document becomes much easier to understand and navigate for all users. Sighted users rely on text size and bold to identify different sections, properly coding those as headings allows users of assistive technology to do the same.
How to fix it
The most efficient way to create headings is to apply the Heading Styles – but this is not the only way. It is possible to apply a paragraph level manually – though this is clearly more prone to errors than using styles. How to fix it
1. In Word, select the text that should become a heading (document title, section titles).
2. Under the Home tab in the Styles group, click the appropriate heading level. If you don't see the heading level you are looking for, click the arrows to browse the full list of preset styles.
3. Apply Heading 1 to the main headings, and Headings 2, 3 etc to subheadings.
4. Do not mix heading order, e.g. Heading 1, Heading 3, Heading 2, the headings should always be in sequence.
5. Repeat these steps for all the text that should become headings.

Error: The headings in this document do not begin at level 1
WCAG 2.1 - 1.3.1 Info and Relationships
Major issue
Explanation
The headings in this document don't begin with heading 1 and therefore don't follow a logical order. Having the main heading at the beginning of the document will provide a more logical structure and will make the document much easier to understand and navigate for all users.
For standard documents, the title of the document should be Heading 1.
Notes
Word’s accessibility checker will not identify this issue if no Styles have been used
How to fix it
Open the Word document and change the title of the document to title style and main heading to Heading 1.
Error: The headings in this document do not follow a logical structure
WCAG 2.1 - 1.3.1 Info and Relationships
Major issue
Explanation
Headings should be hierarchical, starting at heading level 1 for the title of the document, then heading level 2 for the sections of the document, then heading level 3 for subsections, and so on. Heading levels should not be skipped, i.e. a Heading 3 should only appear a section starting with a Heading 2.
How to fix it
In Word, go to View and open the Navigation Pane. This will allow you to get a quick look at the heading structure. Check to see that the correct sections are nested under their parent section. Word’s default is to only show Heading 1-3 in the Navigation Pane, to show more levels right click the Navigation pane, select ‘Show Heading Levels’ and the select the required level from the list or select ‘All’. This setting will not be retained when you close and reopen the file.

Click through the headings of the document to uncover any skipped heading levels (e.g. going from heading level 2 to heading level 4) - the accessibility checker in Word will call out skipped headings.
Ex:
Heading 1
-Heading 2
--Heading 3
--Heading 3
-Heading 2
---Heading 4 (should be H3)
--Heading 3
Error: This document has contrast issues
WCAG 2.1 - 1.4.3 Contrast (Minimum)
WCAG 2.1 - 1.4.6 Contrast (Enhanced)
Major issue
Explanation
This document contains text with low contrast between the text and its background. This can cause the text to be difficult to read, especially for those with low vision, poor eyesight, or colour blindness.
How to fix it
Change any light font colours to a darker shade. If Styles have been used, then adjust the colour for the relevant Style to efficiently ensure consistency.

Check tables - change the colour palette used for tables to increase contrast in header rows.
Use a tool like Who Can Use to check contrast. Use the Office Colour Matrix or UoS Colour Matrix if appropriate. If you need a good colour picker tool use PowerToys (windows) or follow this guide on a Mac.
This 10 minute video presentation has an overview of colour contrast and explains the colour accessibility matrix.
Error: The document does not have a language set
WCAG 2.1 - 3.1.1 Language of Page
Minor issue
Explanation
The document does not specify the language in which it has been created. Certain technologies, such as screen readers, rely on the specified language to determine how to pronounce the document text.
How to fix it
Select Review > Language > Set Proofing Language.
Notes
Word will always have default language. If one is not specified it will pick up the systems default language. 
Error: The document does not have the correct language set
WCAG 2.1 - 3.1.1 Language of Page
Minor issue
Explanation
This document does not specify the correct language in which it has been created. Certain technologies, such as screen readers, rely on the correct language being specified to determine how to pronounce the document text.
Notes
It is possible to have multiple languages in a document as language settings can be set at the Style level
How to fix it
Select Review > Language > Set Proofing Language.
Error: The document's heading structure goes beyond six levels
WCAG 2.1 - 1.3.1 Info and Relationships
Minor issue
Explanation
The headings in this document go beyond six levels. Most technologies, including screen readers and other assistive technology, are limited to six levels of headings. Going above this can cause these headings to not be represented or read appropriately. Word can create up to 9 levels of heading.
How to fix it
In Word, review your heading structure by going to the View tab and opening the Navigation pane. See if you can reduce the number of sections by using bulleted, numbered, or outlined lists instead. Word’s default is to only show Heading 1-3 in the Navigation Pane, to show more levels right click the Navigation pane, select ‘Show Heading Levels’ and the select the required level from the list or select ‘All’. This setting will not be retained when you close and reopen the file.
Make sure your headings are labelled hierarchically (heading 3s are nested under heading 2s) and that you are not assigning them chronologically (heading 1, then 2, then 3, then 4, 5, etc.).
Error: The document has images without alternative descriptions
WCAG 2.1 - 1.1.1 Non-text Content
Major issue
Explanation
This document contains images that don't have a description or alternative text. People with screen readers or other assistive devices rely on these descriptions to understand the image content and purpose. Alt text will also display if an image doesn't load - benefitting everyone.
Notes
Word’s accessibility checker will identify images without Alt text. However, some versions of Office apply a ‘best guess’ for Alt text so it’s worth checking the Alt text of all images is meaningful.
How to fix it
Can you write alternative text without knowing the context of the image?
Yes: Right click on the image (Shift + F10), select Format Picture, under Properties and Layout open the Alt Text pane, enter text in the Description field (not the Title field)
No: log the filename and a screenshot of the image. A meeting will be arranged with the instructor to review unresolved issues.
[bookmark: _Error:_The_document]Error: The document has tables that don't have any headers
WCAG 2.1 - 1.3.1 Info and Relationships
Major issue
Explanation
This document contains tables that don't have or properly specify a header structure. People with screen readers or other assistive devices rely on a correct heading structure to help them navigate the table and match the headings to the data cell.
[bookmark: _How_to_fix]How to fix it
1. Highlight the header row.
2. Right click within the header row you have highlighted and select Table properties, and then select the Row tab.
3. Tick “Repeat as header row at the top of each page”
4. Untick “Allow row to break across pages”
Save the document and upload to Ally. Ideally to be sure the table has been successfully updated create an mp3 version using Ally and listen to the part where the table is said aloud.
A table that looks like this:
	Person
	Skill
	Enemy

	Batman
	Detective
	The Joker

	Superman
	Flying
	Lex Luther



Should be read aloud as
“Begin table with 3 columns and 3 rows.
Row 1 of 3, Column 1 of 3, Column Heading – Person
Row 1 of 3, Column 2 of 3, Column Heading – Skill
Row 1 of 3, Column 3 of 3, Column Heading – Enemy
Row 2 of 3 
Column 1 of 3 with Column Heading Person, Batman
Column 2 of 3 with Column Heading Skill, Detective
Column 3 of 3 with Column Heading Enemy, The Joker
Row 3 of 3
Column 1 of 3 with Column Heading Person, Superman
Column 2 of 3 with Column Heading Skill, Flying
Column 3 of 3 with Column Heading Enemy, Lex Luther”
You know a table is properly remediated when after header row the mp3 file announces the heading of each row as it reads it.
Notes
Word’s accessibility checker will identify this issue
The ‘Repeat Header row’ feature can also be found in the Data group on the Table Tools Layout tab. The Header Row tick box in the Table Style Options group on the Table Tools Design tab does not do the same thing. This button merely applies visual formatting to the top row.
Error: The document is malformed
Severe issue
Explanation
These documents are malformed and therefore cannot be opened and viewed by many or even most people. While some technologies might be able to deal with some malformed documents, there is no guarantee that everyone will be able to view the document or that the formatting and content will be as intended.
How to fix it
It is very unlikely you can fix this document. Log the filename, location in course, and error.

File is a PDF
In most cases the original file from which the PDF was created should be remediated.
Log the detail of the file name and title. 

[bookmark: _Is_the_PDF]Is the PDF a journal article / scan of a textbook?
In some cases, a more accessible PDF may be available. Check https://library.soton.ac.uk/az.php for the publisher and attempt to access. Find the article and copy the link or DOI details.
Add the link, and remove the document?
With Ally you can add Library references using the interface
1. Open the ally view of the file
2. Select “How to fix this”
3. When asked, “Can you get hold of an original or text-based version of this file”, select No
4. When asked, “Can this document be found in the library”, select Yes
5. Complete details as required
If it is not in the library make a note of the file, location in the course, and from where the document may have originated. The team will work with the instructor to determine the best course of action.
Should we ask Allies to use Talis Aspire? Or contact the library digitisation service? 

Error: The document is scanned but not OCR’d
WCAG 2.1 - 1.4.5 Images of text
Severe issue
Explanation
These documents are either entirely scanned or contain pages that are scanned. This means it is an image of a document and the text cannot be accessed by assistive technology. Scanned documents, especially those of poor quality or those containing handwriting, can be difficult to read for everyone. They also have other usability issues such as not being able to search inside the document.
How to fix it
Blackboard Ally will offer an OCR’d alternative file format. 
Is it a journal article / scan of a textbook? See above.
In general, we will want to provide a better version, and this will depend on the nature of the document, it may be a library resource, or it may be a handwritten document.
Make a note of the file, location in the course, and from where the document may have originated. The team will work with the instructor to determine the best course of action.
With Ally you can add Library references using the interface
6. Open the ally view of the file
7. Select “How to fix this”
8. When asked, “Can you get hold of an original or text-based version of this file”, select No
9. When asked, “Can this document be found in the library”, select Yes
10. Complete details as required

Error: This PDF has no title
WCAG 2.1 – 2.4.2 Page Titled
Minor issue
Explanation
PDF titles are used as the document title for a PDF window or tab, making it easier to navigate to the PDF and understand the purpose of the PDF. Often the default is the file name which may not be meaningful/descriptive.
How to fix it
1. Open the PDF with Adobe Pro. 
2. Select Files > Properties > type or paste a meaningful/descriptive title in the Title field.
3. Select the Initial View tab and set the Show field to Document Title
Notes
The title should be brought across when a Word file is converted to PDF, however, having that appear as the Window’s title will not occur automatically

Error: This PDF does not have a language set
WCAG 2.1 - 3.1.1 Language of Page
Minor issue
How to fix it
1. Open the PDF with Adobe Pro.
2. Select Files > Properties > Advanced > select language
Notes
This is a setting that should be brought across when a Word file is converted to PDF
Other possible errors:
Error: This PDF contains images that are missing an alternative description
WCAG 2.1 - 1.1.1 Non-text Content
Major issue
Notes
Remediate in the source file and convert to PDF. This means that if the source file needs other amendments this change will be detained and converted in any future PDF
Error: This PDF has contrast issues
WCAG 2.1 - 1.4.3 Contrast (Minimum)
WCAG 2.1 - 1.4.6 Contrast (Enhanced)
Major issue
Error: The headings in this PDF do not follow a logical structure
WCAG 2.1 - 1.3.1 Info and Relationships
Minor issue
Error: The document is untagged
WCAG 2.1 - 1.3.1 Info and Relationships o
WCAG 2.1 - 1.3.2 Meaningful Sequence
Major issue
All of these issues are best remediated by having the original file. 



File is a PowerPoint
Error: The presentation is malformed
Severe issue
Explanation
These documents are malformed and therefore cannot be opened and viewed by many or even most people. While some technologies might be able to deal with some malformed documents, there is no guarantee that everyone will be able to view the document or that the formatting and content will be as intended.
How to fix it
It is very unlikely you can fix this document. Log the filename, location in course, and error.

Error: This presentation is not marked up with a language / The presentation does not have the correct language set
WCAG 2.1 - 3.1.1 Language of Page
Minor issue
Explanation
Ally cannot determine the language set for the document.
How to fix it
This issue is difficult to solve currently and can be ignored for now but log the file details and this warning.
Error: The presentation has images without alternative descriptions
WCAG 2.1 - 1.1.1 Non-text Content
Major issue
Explanation
This presentation contains images that don't have a description or alternative text. People with screen readers or other assistive devices rely on these descriptions to understand the image content and purpose. Alt text will also display if an image doesn't load - benefitting everyone.
How to fix it
Can you write alternative text without knowing the context of the image?
Yes: In PowerPoint, select the image, select the Picture Format menu, select the Alt Text button. 
No: log the filename and a screenshot of the image. A meeting will be arranged with the instructor to review unresolved issues.


Error: The presentation has text with insufficient contrast
WCAG 2.1 - 1.4.3 Contrast (Minimum)
WCAG 2.1 - 1.4.6 Contrast (Enhanced)
Major issue
Explanation
This presentation contains text with low contrast between the text and its background. This can cause the text to be difficult to read, especially for those with low vision, poor eyesight, or colour blindness.
How to fix it
Change any light font colours to a darker shade.

Check tables - change the colour palette used for tables to increase contrast in header rows.
Use a tool like Who Can Use to check contrast. Use the Office Colour Matrix or UoS Colour Matrix if appropriate. If you need a good colour picker tool use PowerToys (windows) or follow this guide on a Mac.
Watch out for text over images. In some cases, it is better to add a background colour to the text to make the text readable. Ensure the background colour you choose has sufficient contrast to the text colour.
This 10 minute video presentation has an overview of colour contrast and explains the colour accessibility matrix.


Error: The presentation does not have any headings
This accessibility check enforces a minimum of 1 title for every 7 slides in a PowerPoint document.
WCAG 2.1 - 1.3.1 Info and Relationships
Major issue
Explanation
This presentation doesn't contain any marked-up headings, these are likely to be titles. Titles are important as they provide structure to a presentation, especially those that consist of many slides. When titles are properly and consistently used, the document becomes much easier to understand and navigate for all users, particularly users of assistive technology. The alternate formats will be much more understandable and usable when titles are included.
How to fix it
You can use the accessibility inspector to help with this.
Alternatively, select the View menu, and choose Outline View. Add slide titles to the slides. Be careful that titles do not obscure content already within the slide. If the slide has content in place already, put the title below the content.
Error: The presentation has tables that don't have any headers
WCAG 2.1 - 1.3.1 Info and Relationships
Major issue
Explanation
This presentation contains tables that don't have or properly specify a header structure. Users of screen readers or other assistive devices rely on a correct heading structure to help them navigate the table and match the headings to the data cell. The audio alternate format will be much more understandable and usable when headers are marked up in presentation tables.
How to fix it

TBC, issues found, community post written and support ticket to be raised
For now, use the PowerPoint accessibility checker to fix the table.

File is an image
Error: The image can induce seizures
WCAG 2.1 - 2.3 Seizures
Severe issue
Explanation
Ally has detected that an animation can potentially induce a seizure.
How to fix it
In your log note the image filename, that it may cause seizures and its location within the course. Remediation will be discussed with the instructor.
Error: The image has text that is not part of the alternative description
WCAG 2.1 - 1.4.5 Images of text
Minor issue
Explanation
Ally has detected text within the image that does not match the text in the alternative description. This suggests that the alternative text has room for improvement so that those unable to view the image may still obtain the maximum meaning from the alt text.
How to fix it
Review the current alternative text and seek to improve it so that it includes any text that makes up part of the image.
Error: Image has no alternative text
WCAG 2.1 - 1.1.1 Non-text Content
Major issue
Explanation
Those who cannot view the image will be unable to determine the meaning it was meant to convey.
How to fix it
Can you write alternative text without knowing the context of the image?
Yes: write alternative text and save in Ally.
Log the filename and the alternative text you use.
No: log the filename and a screenshot of the image. A meeting will be arranged with the instructor to review unresolved issues.
Notes
Alt text is best remediated in the source file so future conversions will access the new Alt text
Error: The image has contrast issues
WCAG 2.1 - 1.4.3 Contrast (Minimum)
WCAG 2.1 - 1.4.6 Contrast (Enhanced)
Major issue 
Explanation
Where text is used in the image, Ally may detect there is not enough contrast. Lacking sufficient contrast means those with a visual or relevant situational impairment will have difficulties establishing the full meaning they are meant to derive from the image.
How to fix it
To resolve this may require the original image in photoshop format, or to recreate the image afresh.
Log the filename and a screenshot of the image. A meeting will be arranged with the instructor to review unresolved issues.
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